[NZLUG] Python upgrade issues

jsr at ecofluidics.com jsr at ecofluidics.com
Tue Mar 29 11:24:20 NZDT 2016


Hi 

I am having some issues with Python. Everything worked fine until I started using statsmodels. Python recognizes the function calls but that is about all. There is something seriously wrong somewhere. 

So I decided to upgrade statsmodels. Synaptic reports "Could not apply changes! Fix broken packages first." Synaptic couldn't handle fixing broken packages and popped a list of weird errors so I ran "aptitude install -f" etc from the command line. Still no joy. 

I have Python 2.7.5 installed. (Also Python3 as 3.3.2 but Python 3 cannot even find numpy.) 

When I search the forums for advice on how to upgrade Python there are numerous parallel methods recommended: easy_install, pip, wget methods etc. etc. I am cautious about committing to any of these until I am sure it works because I don't want to wreck my existing intallation. I am also increasingly suspicious of Synaptic. 

All I really want to do is install a working version of statsmodels. I have version 0.4.2 installed which doesn't work. I believe 0.6.1 is available but I don't know how to install it. 

Thanks 

John Reid 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.nzoss.org.nz/pipermail/nzlug/attachments/20160329/6dd55241/attachment.html>


More information about the NZLUG mailing list