[NZLUG] VNC server/viewer setup help required

Reed Wade reed at typist.geek.nz
Sun Jul 17 19:16:50 NZST 2016


Are you sure the localhost option is not set in your server config file?

-reed


On 17 July 2016 at 18:44, Patrick Connolly <tuxkid at slingshot.co.nz> wrote:

> Somewhere about Fri, 15-Jul-2016 at 11:21AM +1200 (give or take),
> Cliff Pratt wrote:
>
> |> On 14/07/16 20:20, Patrick Connolly wrote:
>
> ...
>
> |> ># netstat -tlnep | grep -E '5901|6001'
> |> >tcp        0      0 127.0.0.1:5901          0.0.0.0:*
>  LISTEN      1000       3579449     31417/Xvnc
> |> >tcp        0      0 0.0.0.0:6001            0.0.0.0:*
>  LISTEN      1000       3579444     31417/Xvnc
> |> >tcp6       0      0 ::1:5901                :::*
> LISTEN      1000       3579450     31417/Xvnc
> |> >tcp6       0      0 :::6001                 :::*
> LISTEN      1000       3579443     31417/Xvnc
> |> >
> |> >I've disregarded the tcp6 lines assuming they don't tell anything new.
> |> >Is that a bad idea?
> |> >
> |> >
> |> >#
> ....
>
> |> >
> |> Well, that first line of the netstat *seems* to say that 5901 is
> |> open on localhost only, so any connections will need connect to
> |> localhost, which of course they can't from another machine.
>
> Are there any suggestions as to how to make the :5091 line more like
> the :6001 line.
>
> |>
> |> Try 'telnet <ip addr of the remote machine> 5901 from the other
> |> machine and see if it connects. My guess is that it won't.
>
> There's no telnet on the Windows machine so can't test that theory.
>
> |>
> |> The setup looks to me like it is expecting the connection to the
> |> remote machine to be via an SSH tunnel. Is this the case?
>
> The ultimate aim is to use putty to make the connexion.  Once that's
> established, the idea is to start the vnc server, then use Tigervnc
> viewer to use the Linux machine as if being there.  A bash prompt in a
> putty window is not sufficient.
>
> Were only one person using the Linux machine, it would be very simple
> to use display :0 using x11vnc, but that's no use in this case.
>
> |>
> |> In your ~/.vnc/config you said you had a line with "localhost". You
> |> could maybe try removing that? I don't have such a file on my
> |> system.
>
> Yes, I did try that and many other omissions and variations.  I've no
> idea if these lines in syslog have any bearing.  Looking around, I see
> it turns up all sorts of places but I don't see anything to indicate
> it is an issue here.
>
> console-kit-daemon[31640]: WARNING: Failed to acquire
> org.freedesktop.ConsoleKit
> console-kit-daemon[31640]: WARNING: Could not acquire name; bailing out
>
> My Windows helper says he needs to look at the workings of the viewer.
> He thinks there might be something there that defies the 'ESTABLISHED'
> message.  I'll try connecting this Mint box to a CentOS laptop and see
> if that sheds any light.
>
> Thanks for your suggestions.
>
> --
>    ___     Patrick Connolly
>  {~._.~}
>  _( Y )_          Good judgment comes from experience
> (:_~*~_:)         Experience comes from bad judgment
>  (_)-(_)
>
> _______________________________________________
> NZLUG mailing list
> NZLUG at lists.nzoss.org.nz
> http://lists.nzoss.org.nz/mailman/listinfo/nzlug
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.nzoss.org.nz/pipermail/nzlug/attachments/20160717/6867d35b/attachment.html>


More information about the NZLUG mailing list