[NZLUG] VNC server/viewer setup help required

tuxkid tuxkid at slingshot.co.nz
Wed Jul 13 14:27:16 NZST 2016


On 2016-07-13 13:18, Martin D Kealey wrote:
> On Wed, 13 Jul 2016, tuxkid wrote:
>> I've already tried x = 1, 2, 3, 4, 100, 200 with the same result.  The
>> server says it's listening on port 5900 + x, but the viewer will only 
>> ever
>> establish a connexion to 6000 + x.
> 
> VNC and X have opposite ideas of which ends are the "client" and the
> "server", so a proxy between them acts as "server" on both sides.
> 
> So xvnc listens on *two* ports -- one as a VNC server, and one as an X
> server; and I gather that they're numbered 5900+x and 6000+x. Note that 
> 6000
> is the default X server using the local keyboard and screen (often 
> VT7);
> picking numbers bigger than 99 are not likely to work as you'd expect.
> 
> If it seems like one listener appears but the other does not, check 
> netstat.
> If netstat says there are two listeners, check your firewall rules. If

> netstat -lt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         
State
tcp        0      0 *:netbios-ssn           *:*                     
LISTEN
tcp        0      0 localhost:5901          *:*                     
LISTEN
tcp        0      0 *:x11-1                 *:*                     
LISTEN
tcp        0      0 *:ssh                   *:*                     
LISTEN
tcp        0      0 localhost:ipp           *:*                     
LISTEN
tcp        0      0 *:db-lsp                *:*                     
LISTEN
tcp        0      0 *:microsoft-ds          *:*                     
LISTEN
tcp        0      0 localhost:17600         *:*                     
LISTEN
tcp        0      0 localhost:17603         *:*                     
LISTEN
tcp        0      0 *:gnunet                *:*                     
LISTEN

Meantime,
> netstat -nt
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         
State
tcp       32      0 10.10.102.68:47368      10.16.1.30:8080         
CLOSE_WAIT
tcp       32      0 10.10.102.68:47766      10.16.1.30:8080         
CLOSE_WAIT
tcp        0      0 10.10.102.68:47073      10.16.1.30:8080         
ESTABLISHED
tcp        0      0 10.10.102.68:22         10.10.102.66:64602      
ESTABLISHED
tcp       32      0 10.10.102.68:47364      10.16.1.30:8080         
CLOSE_WAIT
tcp       32      0 10.10.102.68:47767      10.16.1.30:8080         
CLOSE_WAIT
tcp       32      0 10.10.102.68:46328      10.16.1.30:8080         
CLOSE_WAIT
tcp        0      0 10.10.102.68:22         10.10.102.66:63637      
ESTABLISHED
tcp       32      0 10.10.102.68:47367      10.16.1.30:8080         
CLOSE_WAIT
tcp        0      0 10.10.102.68:47769      10.16.1.30:8080         
ESTABLISHED
tcp       32      0 10.10.102.68:47366      10.16.1.30:8080         
CLOSE_WAIT
tcp        0      0 10.10.102.68:6001       10.10.102.66:63847      
ESTABLISHED

Using netstat 2 different ways (neither of which I really follow) it 
looks as though both 5901 and 6001 are listening.  I don't have a 
firewall since both machines are behind the organisation's firewall.


> netstat says there is only one listener, then check your VNC config.

What should I look  for in the ~/.vnc/config?  It's like this:

securitytypes=vncauth,tlsvnc
desktop=sandbox
geometry=1680x1050
localhost
alwaysshared

Should I  remove  the first line?

Thanks

PC

> 
> -Martin
> _______________________________________________
> NZLUG mailing list
> NZLUG at lists.nzoss.org.nz
> http://lists.nzoss.org.nz/mailman/listinfo/nzlug


More information about the NZLUG mailing list